由于在Servlet的讨论中经常涉及到这部分知识内容,所以单独把这部分内容提出来做个介绍;内容包括了传统的邮件格式和扩展之后的邮件格式的讨论,并都以例子来做讲解,尽量做到通俗易懂!
(Multipurpose Internet Mail Extensions)
从字面上可以翻译为:多用途互联网邮件扩展;MIME表示一种邮件格式的规范;从其字面意思就可知:它是对原先的邮件格式进行了扩展,使其用途比之前的邮件用途广的多。那么你也许会问:为什么要扩展原先的邮件格式规范呢?原先的邮件有什么不足?MIME这种类型的邮件又有什么样的特点?
原先邮件的不足之处
在MIME出现之前,互联网电子邮件主要遵循由RFC822所制定的标准,电子邮件一般只用来传递基本的ASCII码文本信息,并且早期的RFC822所使用的字符集是7位的US-ASCII编码,在这种情况下,不要说其他多媒体信息,就连有些语言文字都无法正确编码,也就无法传递。
下面是一个传统的邮件格式:
1.Return-Path: <it315_test@sina.com>
2.Delivered-To: it315_test@sohu.com
3.Received: from smtp.sina.com.cn (unknown [202.108.3.177])
4. by sohumx139.sohu.com (Postfix) with SMTP id E4F9802C1249
5. for <it315_test@sohu.com>; Thu, 10 Nov 2005 16:39:50 +0800 (CST)
6.Received: (qmail 49221 invoked from network); 10 Nov 2005 08:39: 33 -0000
7.Received: from unknown (HELO it315?test) (218.246.5.151)
8. by smtp.sina.com.cn with SMTP; 10 Nov 2005 08:39:33 -0000
9. From: it315_test@sina.com
10.To: it315_test@sohu.com
11.subject:test
12.Message-Id: <20051110083950.E4F9802C1249@sohumx139.sohu.com>
13.Date: Thu, 10 Nov 2005 16:39:50 +0800 (CST)
14.Status: RO
15.X-UIDL: 1131611863.21509_77.mx72
16.
17.test!!!
说明:
上例中的第1~15行是邮件的邮件头,第17行是邮件的邮件体,邮件头和邮件体之间以一个空行进行分隔。
这封邮件的邮件体内容非常少,只有一行“test!!!”文本。邮件头部分由多个字段组成。
可能你在你自己将要发送的邮件源文件中看到实际发送的邮件头少了一些字段,这些少了的头字段是各个SMTP服务器在传递邮件的过程加上的。
SMTP服务器在传递邮件时,会把一些相关信息增加到邮件的邮件头中,这种情况有点类似于现实生活中的邮局在处理邮件时,通常都会在信封上加盖邮戳一
1 MIME 邮件格式分析 MIME 技术规范的完整 内容 由 RFC 2045-2049 定义,包括了信息格式、媒 体类型、编码方式等各方面的内容,这里我们只介绍其中的一些关键的...
MIME协议及邮件格式分析_信息与通信_工程科技_专业资料。MIME和邮件相关格式解析...每种邮件编码方式的介绍如下: — 7Bit 指消息体内容全部是没有经过编码的 ...
什么是MIME 11页 1财富值喜欢此文档的还喜欢 9.POP3协议 12页 1财富值 MIME格式详细介绍 11页 1财富值 MIME邮件格式简介 8页 免费 MIME 28页 2财富值 ...
基于MIME的邮件自动收发系统的实现_专业资料。介绍了MIME邮件的标准和规范,研究了邮件的组成、结构,以及在Internet环境下MIME邮件的发送/接收原理。采用适应性较强的...
电子邮件安全(2) S/MIME 本节内容 ? 1. 传统电子邮件格式——RFC 5322 ? 1.1 RFC 5322简介 ? 1.2 举例:一条RFC 5322消息 ? 1.3 SMTP/5322方案的缺陷...
MIME邮件格式简介 8页 免费 HTTP协议(RFC2616)中文版... 105页 1下载券 ...RFC2633—S/MIME Version 3 Message Specification S/多用途网际邮件扩充协议(...
MIME详解 9页 1下载券 MIME类型 7页 1下载券 MIME一览 7页 免费 什么是MIME类型 2页 免费 MIME解析 9页 免费 喜欢此文档的还喜欢 MIME邮件格式简介 8页 ...
86析MIME邮件组成结构及构建邮件收发系统_IT/计算机_专业资料。MIME邮件的格式...介绍了MI ME的基本标准, 分析了MI ME娜件的组成结构, 详细介绍 了邮件头, ...
简介MIME 类型就是设定某种扩展名的文件用一种应用程序来打开的方式类型, 当该...MIME 能够支持非 ASCII 字符、二进制格式附件等多种格式的邮件消息。这 个标准...
MIME协议及邮件格式分析 16页 1下载券 MIME邮件格式简介 8页 1下载券...MIME 报文格式 From: alice@crepes.fr To: bob@hamburger.edu Subject: ...
热门文档