文档下载 文档下载导航
设为首页 | 加入收藏
搜索 请输入内容:  
 导航当前位置: 文档下载 > 所有分类 > 工程科技 > 信息与通信 > MIME协议及邮件格式分析
侵权投诉

MIME协议及邮件格式分析

MIME和邮件相关格式解析

电子邮件也许是一个Internet上的流行最广泛的应用。也是我们现在的大多数网络办公流程的基础。各种邮件服务器很多,但都大都遵循以1982年出版的RFC822--《ARPA网络文本信息格式标准(STANDARD FOR THE FORMAT OF ARPA INTERNET TEXT MESSAGES)》为基础的一系列邮件格式的规定。

RFC(The Requests for Comments)是用来规定互联网工作标准的文档。我们使用的时候并没有注意到这些协议在我们的邮件通信过程中默默的发挥着的作用,这丝毫也不能减低这些作用的重要性。邮件内部还有很多不为人知的秘密。

在RFC822中规定一封信包括一个必须的多个头部域(header fields)和一个可选的体部(body)组成。从一封信头开始至第一个空行都是头部。头部定义了一个邮件的各项基本要素,路由信息等内容。

在Outlook Express中选定一封信看它的属性。在详细资料选项卡中显示的就是这封邮件的头部内容。也可以选定一封信,另存为一个.eml文件。由于文件是一个纯文本文件,用一般的编辑器打开就可以看到邮件的内容。

头部有各个头部域组成,每一个头部域都包括域名(field-name)和域体(field-body),它们之间以":"分隔。每一个头部域都可以看作由ASCII码字符组成的独立的文本。常见的头部域包括:"Return-Path", "Received", "Date", "From", "Subject", "Sender","To", "cc","MIME-Version"等。各头部域之间没有规定顺序。 就像各个域的名字一样。他们表示的具体意义也不同。

Return-Path域表示退信的地址。

Received域表示路由信息。

Internet上的信件可能是由多个服务器依靠协议传递到达最终的目的邮箱的。每一个服务器都会把自己的一段

Received域信息添加近信件。所以可能有多段Received域,依传递次序排列。这个域的内容很有意思,我们可以根据每一段的内容来跟踪一封信在internet上的传递过程。网管人员也可以根据这些信息做出很有价值的判断。

例如一段代码中

Received: from unknown (unknown [202.108.44.208]) by mx7.163.com (Postfix) with SMTP id 74E0E8 for; Fri, 28 Feb 2003 18:10:25 +0800 (CST)中,from 表示发送主机,by表示接受主机,via物理路径(本例没有),with表示使用的协议,id表示接受消息号,for表示目的邮件地址,分号后面表示时间。

Date域表示建立信件的时间。

From域表示邮件作者。

Subject域就是邮件的主题。

Sender域表示邮件的实际发送者。

To,cc域都表示接受的邮件地址。

MIME-Version域表示MIME的版本(以后扩充的域)

还有一个域—Content-Type。标识了一个重要的概念:邮件内容的格式。这个域的内容根据互联网的发展产生,使邮件可以用来传输非文本内容,在RFC822中并没有定义,而是在后续的RFC2045,RFC2046等文档中有定义。

还有一些不太常见的头部域,如"References","Message-ID"域。以及一些由不同厂家定义的自己的域(域名以"X-"开头)。

知道了这些知识,就可以看懂邮件头部。了解到那些邮件的秘密。

比如这是一封邮件的头部。

Return-Path: "sea"

Received: from unknown (unknown [202.108.44.208])

by mx7.163.com (Postfix) with SMTP id 74E0E8

for ; Fri, 28 Feb 2003 18:10:25 +0800 (CST)

Received: from smtp.netcs.com (unknown [211.150.100.6])

by 192.168.1.208 (Coremail:doc.guandang.net) with SMTP id cAsAAJY1Xz7kAmQG.1

for ; Fri, 28 Feb 2003 18:10:30 +0800 (CST)

Received: from sea (unknown [192.168.18.160])

by smtp.netcs.com (Postfix) with ESMTP id E55D02675F

第1页

你可能喜欢

  • 邮件系统
  • 协议分析
  • HTTP协议详解
  • 电子邮件格式
  • 电子邮件协议
  • ftp协议
  • DNS协议
  • 传输协议

热门文档

相关文档

  • mime协议

    MIME 结构一, RFC822 协议 RFC822 文档定义了邮件内容的主体结构和各种邮件头字段的详细细节,但是,它没有 定义邮件体的格式,RFC822 文档定义的邮件体部分通常都...

  • MIME邮件格式分析及信息提取

    MIME邮件格式分析及信息提取_IT/计算机_专业资料。邮件开发中如何分析邮件内容... MIME协议及邮件格式分析 16页 1下载券 09.Interoperability_In... 暂无评价 ...

  • MIME邮件格式简介

    MIME邮件格式简介_IT/计算机_专业资料。由于在Servlet的讨论中经常涉及到这部分... MIME协议及邮件格式分析 16页 1下载券 MIME邮件格式分析及信息... 4页 免费...

  • MIME协议浅析

    MIME 协议分析第1 章. MIME 概述 MIME,全称为“Multipurpose Internet Mail ...MIME 试图在不改变 SMTP 协议和 RFC822(邮件格式标准)的基础上,使得邮 件可以...

  • RFC2633-S多用途网际邮件扩充协议(MIME) 版本 3 信息说...

    HTTP协议(RFC2616)中文版... 105页 1下载券 MIME协议及邮件格式分析 16页 ...RFC2633—S/MIME Version 3 Message Specification S/多用途网际邮件扩充协议(...

  • 电子邮件协议威胁及分析

    电子邮件协议威胁及分析_互联网_IT/计算机_专业...关键词:SMTP;POP3;IMAP;MIME;漏洞和攻击;对策; ...命令与响应也都是用 NVT ASCII 格式 的文本表 示...

  • MIME

    MIME协议及邮件格式分析 16页 1下载券MIME 暂无评价0人阅读0次下载举报文档小野编程 http://hi.baidu.com/小野编程/home 1.6 MIME 浏览器...

  • 邮件客户机分析

    MIME协议及邮件格式分析 16页 1下载券邮件客户机分析 暂无评价0人阅读0次下载举报文档电子邮件发件实验 电子邮件流程 服务器A ...

  • 电子邮件协议综述

    被解析出来后,邮件程序便开始使用 TCP 协议连接邮件...(S-MIME) ) 安全电子邮件管理协议(S-MIME),主要...说明了 如何安排消息格式使消息在不同的邮件系统内...

  • 第三章 MIME

    9.POP3协议 12页 1财富值 MIME格式详细介绍 11页 1财富值 MIME邮件格式简介 8页 免费 MIME 28页 2财富值 MIME协议及邮件格式分析 16页 2财富值...

站点地图 | 文档上传 | 侵权投诉 | 手机版
本站所有资源均来自互联网,本站只负责收集和整理,均不承担任何法律责任,如有侵权等其它行为请联系我们.
文档下载 Copyright 2013 doc.guandang.net All Rights Reserved.  -  email