C++语言 创建窗口
VC++语言创建一个普通的应用程序窗口
首先,打开Microsoft Visual C++6.0软件,从File菜单中选择New。在New对话框中,单击Projects标签,选择Win32 Application。在Location域中,选择一个子目录(即你想把创建的文件放到哪里),在Project name里输入该项目的名称,此时该名称是hellowin,这便是Location域中显示的目录的子目录。应选中Create New Workplace单选钮,在Platforms部分应该指明Win32,选择OK。
将会出现一个标题为“Win32 Application-Step 1 of 1”的对话框,指出要建立一个“An empty project”,按下Finish按钮。在弹出的窗口中再单击OK。
从File菜单中再次选择New。在New中,单击Files标签,选择C++ Source File。应选中Add To Project复选框,并应指明hellowin。在File域中输入hellowin.c,选择OK。
现在输入以下代码:
#include <windows.h>
LRESULT CALLBACK WndProc (HWND, UINT, WPARAM,LPARAM);
int WINAPI WinMain (HINSTANCE hInstance, HINSTANCE hPrevInstance,
PSTR szCmdLine,int iCmdShow)
{
static TCHAR szAppName[]=TEXT("HelloWin");
HWND hwnd;
MSG msg;
WNDCLASS wndclass;
wndclass.style =CS_HREDRAW|CS_VREDRAW;
wndclass.lpfnWndProc =WndProc;
wndclass.cbClsExtra =0;
wndclass.cbWndExtra =0;
wndclass.hInstance =hInstance;
wndclass.hIcon =LoadIcon(NULL,IDI_APPLICATION);//LoadIcon函数:加载图标供程序使用
wndclass.hCursor =LoadCursor(NULL,IDC_ARROW);//LoadCursor 加载鼠标指针供程序使用
wndclass.hbrBackground =(HBRUSH)GetStockObject(WHITE_BRUSH);
//GetStockObject 获取一个图形对象,在这个例子中,是获取绘制窗口背景的刷子
wndclass.lpszMenuName =NULL;
wndclass.lpszClassName =szAppName;
if(!RegisterClass(&wndclass))//RegisterClass 为程序窗口注册窗口类
{
MessageBox(NULL,TEXT("This program requires Windows NT!"),
szAppName,MB_ICONERROR);//MessageBox 显示消息框
return 0;
}
hwnd=CreateWindow(szAppName,//CreateWindow 根据窗口类创建一个窗口
TEXT("The Hello Program"),
WS_OVERLAPPEDWINDOW,
CW_USEDEFAULT,
CW_USEDEFAULT,
CW_USEDEFAULT,
CW_USEDEFAULT,
NULL,
NULL,
hInstance,
NULL);
ShowWindow(hwnd,iCmdShow);//ShowWindow 在屏幕上显示窗口
UpdateWindow(hwnd);//指示窗口刷新自身
while(GetMessage(&msg,NULL,0,0))//从消息队列中获取消息
{
TranslateMessage(&msg);//转换某些键盘消息
DispatchMessage(&msg);//将消息发送给窗口过程
}
return msg.wParam;
}
LRESULT CALLBACK WndProc (HWND hwnd,UINT message,WPARAM wParam,LPARAM lParam)
{
HDC hdc;
PAINTSTRUCT ps;
RECT rect;
switch(message)
{
case WM_CREATE:
PlaySound(TEXT("Windows XP 启动.wav"),NULL,SND_FILENAME|SND_ASYNC);
//PlaySound 播放一个声音文件
//为了使PlaySound函数能正常使用,编译前应做以下设置:单击Proj
VC++6.0教程_C语言_工具_计算机软件及应用_IT/...“C++ Source ”,一般都是建立这种 文件的 (适用...程序与用户交互是通过一个标准的正文窗口,下面我们将...
第一章 VC++Windows应用程序与MFC_计算机/互联网_科技_PPT专区。第1章 基础...窗口的使用过程: 定义窗口类对象、设置窗口属性、注册窗口、创建 窗口、显示窗口...
用简练的语言叙述例程的创建过程,让读者在实践中摸索操作的经验,为今后继续登入 VC++的殿堂奠定坚实的基础。 本章要点 1 了解创建应用程序的一般步骤 2 学会创建...
如何通过代码获得应用程序主窗口的 指针 VC++_计算机软件及应用_IT/计算机_专业资料。如何通过代码获得应用程序主窗口的 指针 2008年08月21日 01:28 (1)如何...
VC++的功能强大,用途广泛,不仅可以编写普通的应用程序,还能很好地进行系统 软件设计及通信软件的开发。 二、使用 Visual C++ 6.0 建立 C 语言应用程序利用 VC+...
VC++深入详解 - 窗口的创建_互联网_IT/计算机_专业资料。VC++深入详解 - ...(3)当应用程序接收到某一窗口的消息时,调用DispatchMessage(&msg)将消息回传给...
基于c语言的windows应用程序_计算机软件及应用_IT/...-2- 二、实验环境(实验设备) VC++6.0 -3- ...应用程序和普通程序主 要的不同是,它涉及到窗口的...
语言 VC VB VJ 窗口 菜单 按钮 对话框 程序模块 都是“面向对象” 的程序...(3)句柄 ? (4)消息 5 (1) 窗口一个应用程序的窗口一般包含下列成分:控制...
VC++6.0中如何编译运行C语言程序_IT/计算机_...具有高度可视化的应用程序开发工具,不仅适合大型软件的...(图7) 在下端的输出窗口会有错误和警告的提示,...
C语言创建窗口代码_IT/计算机_专业资料。C语言创建窗口代码#include <windows....(hdc,0,50,"VC++程序设计", strlen("VC++程序设计")); ReleaseDC(hwnd,...
热门文档